Skip to main content
VulnerabilityPublished

CVE-2025-53107: cyanheads git-mcp-server · Command Injection

Affects cyanheads git-mcp-serverSource CVE Database V5

0

Not known to be exploited · 24% EPSS · CVSS 7.5 High : upgrade to 2.1.5 soon.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
24.5% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade @cyanheads/git-mcp-server to 2.1.5.

Affected software

ProductAffectedFixed in
npm@cyanheads/git-mcp-serverpkg:npm/@cyanheads/git-mcp-serverOther threatsAffected
  • <2.1.5
Fixed in
  • 2.1.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade cyanheads git-mcp-server to version 2.1.5 or later, where the vulnerability is patched. If upgrading is not immediately feasible, organizations should implement strict input validation and sanitization on all user-supplied parameters interacting with the server. Employing application-layer firewalls or intrusion detection systems to monitor and block suspicious command injection patterns can provide temporary protection. Restricting access to the git-mcp-server to trusted networks and authenticated users reduces exposure. Additionally, running the server with the least privileges necessary limits the impact of potential exploitation. Organizations should audit their MCP client interactions to identify and remediate any indirect prompt injection vectors. Regularly monitoring logs for unusual command execution or shell activity can help detect exploitation attempts early. Finally, integrating secure coding practices and avoiding the use of child_process.exec with unsanitized input in custom extensions or scripts is critical to prevent similar vulnerabilities.

Description

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

References

Community reviews

Loading reviews…