Skip to main content
CVE-2025-53354VulnerabilityPublished

CVE-2025-53354: zauberzeug nicegui · Cross-site Scripting

Affects zauberzeug niceguiSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.0.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade zauberzeug nicegui to 3.0.0.

Affected software

ProductAffectedFixed in
zauberzeug niceguiAffected
  • <3.0.0
Fixed in
  • 3.0.0

AI-suggested

European organizations should immediately upgrade all NiceGUI deployments to version 3.0.0 or later, where the vulnerability is fixed. Until upgrades are completed, developers must audit their applications to identify any use of ui.html() or ui.chat_message components that render user input without proper escaping or sanitization. Input validation and output encoding should be implemented rigorously to neutralize any HTML or JavaScript content before rendering. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Additionally, security teams should monitor web application logs for suspicious input patterns and user behavior indicative of XSS attempts. User education on phishing and suspicious links can reduce the risk from social engineering vectors. Finally, incorporate automated security testing tools that detect XSS vulnerabilities during development and deployment cycles to prevent recurrence.

Description

NiceGUI is a Python-based UI framework. Versions 2.24.2 and below are at risk for Cross-Site Scripting (XSS) when developers render unescaped user input into the DOM using ui.html(). NiceGUI did not enforce HTML or JavaScript sanitization, so applications that directly combine components like ui.input() with ui.html() or ui.chat_message with HTML content without escaping may allow attackers to execute arbitrary JavaScript in the user’s browser. Applications that do not pass untrusted input into ui.html() are not affected. This issue is fixed in version 3.0.0.

References

Community reviews

Loading reviews…