Skip to main content
CVE-2025-53490VulnerabilityPublished Updated

CVE-2025-53490: Wikimedia Foundation Mediawiki – CampaignEvents Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – CampaignEvents ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.6 Medium : upgrade to 1.44.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade wikimedia/mediawiki/extensions/CampaignEvents to 1.44.0.

Affected software

ProductAffectedFixed in
GitHubwikimedia/mediawiki/extensions/CampaignEventspkg:github/wikimedia/mediawiki/extensions/CampaignEventsOther threatsAffected
  • >=1.43.0 <1.44.0
Fixed in
  • 1.44.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should promptly upgrade the CampaignEvents extension to version 1.43.2 or later, where the issue is resolved. If immediate patching is not feasible, organizations should implement strict input validation and output encoding on all user-supplied data rendered by the CampaignEvents extension. Employing Content Security Policy (CSP) headers can help restrict the execution of unauthorized scripts. Regularly auditing Mediawiki extensions for security updates and disabling unused or unnecessary extensions reduces the attack surface. Network-level protections such as Web Application Firewalls (WAFs) configured to detect and block XSS payloads can provide an additional layer of defense. Furthermore, organizations should educate users about the risks of XSS and encourage cautious behavior when interacting with wiki content. Monitoring logs for unusual activity related to the CampaignEvents extension can aid in early detection of exploitation attempts.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - CampaignEvents Extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - CampaignEvents Extension: from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…