Skip to main content
CVE-2025-53492VulnerabilityPublished Updated

CVE-2025-53492: Wikimedia Foundation Mediawiki – MintyDocs Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – MintyDocs ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 3.7 Low : upgrade to 1.44.0 when convenient.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Wikimedia Foundation Mediawiki – MintyDocs Extension to 1.44.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - MintyDocs ExtensionAffected
  • >=1.43.0 <1.44.0
Fixed in
  • 1.44.0

AI-suggested

European organizations should promptly upgrade the MintyDocs Extension to version 1.43.2 or later once available to address this vulnerability. If you cannot patch yet, administrators should implement strict input validation and output encoding on any user-generated content within the MintyDocs Extension. Employ Content Security Policy (CSP) headers to restrict script execution and reduce the impact of potential XSS payloads. Conduct thorough code reviews and penetration testing focusing on input handling in the MintyDocs Extension. Additionally, monitor web server logs and user reports for unusual activity or unexpected script execution. Disable or restrict the use of the MintyDocs Extension if it is not essential to reduce the attack surface. Educate users about the risks of clicking on suspicious links within internal documentation portals. Finally, maintain up-to-date backups and incident response plans to quickly remediate any exploitation attempts.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - MintyDocs Extension allows Stored XSS.This issue affects Mediawiki - MintyDocs Extension: from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…