Skip to main content
CVE-2025-53494VulnerabilityPublished Updated

CVE-2025-53494: Wikimedia Foundation Mediawiki – TwoColConflict Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – TwoColConflict ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 1.44.0 : update Wikimedia Foundation Mediawiki – TwoColConflict Extension when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0, 1.40.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade wikimedia/mediawiki/extensions/TwoColConflict to 1.44.0, 1.43.0 or 1.40.0.

Affected software

ProductAffectedFixed in
GitHubwikimedia/mediawiki/extensions/TwoColConflictpkg:github/wikimedia/mediawiki/extensions/TwoColConflictOther threatsAffected
  • <1.40.0 >=1.39.0
  • <1.43.0 >=1.42.0
  • <1.44.0 >=1.43.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should promptly upgrade the TwoColConflict extension to versions 1.39.13, 1.42.7, or 1.43.2 or later, where the vulnerability has been addressed. In the absence of immediate patching, administrators should implement strict input validation and output encoding on all user-supplied content within the extension, especially in conflict resolution interfaces. Employing Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting script execution sources. Regularly audit Mediawiki installations for unauthorized script injections and monitor logs for suspicious activities. Additionally, limit the extension's usage to trusted users and restrict editing permissions where feasible. Educate users about the risks of clicking unknown links or executing scripts from untrusted sources. Finally, maintain an up-to-date inventory of Mediawiki versions and extensions to ensure timely application of security updates.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - TwoColConflict Extension allows Stored XSS.This issue affects Mediawiki - TwoColConflict Extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…