Skip to main content
VulnerabilityPublished

CVE-2025-53944: Significant-Gravitas AutoGPT · Improper Authorization

Affects Significant-Gravitas AutoGPTSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 0.6.16 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.16
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Significant-Gravitas AutoGPT to 0.6.16.

Affected software

ProductAffectedFixed in
Significant-Gravitas AutoGPTAffected
  • <0.6.16
Fixed in
  • 0.6.16

AI-suggested

European organizations should immediately upgrade AutoGPT to version 0.6.16 or later to remediate this vulnerability. Until patching is possible, organizations should restrict access to the external API endpoints to trusted networks and users, implement strict monitoring and logging of API calls to detect anomalous access patterns, and enforce strong authentication and authorization controls, including multi-factor authentication to reduce the risk of credential compromise. Additionally, organizations should conduct audits of existing execution results access logs to identify potential unauthorized access. Network segmentation and API gateway policies can be employed to limit exposure of the vulnerable endpoint. Developers should review custom integrations with AutoGPT to ensure they do not bypass internal API protections. Finally, organizations should incorporate this vulnerability into their incident response plans and ensure staff are aware of the risk and remediation steps.

Description

AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents. In v0.6.15 and below, the external API's get_graph_execution_results endpoint has an authorization bypass vulnerability. While it correctly validates user access to the graph_id, it fails to verify ownership of the graph_exec_id parameter, allowing authenticated users to access any execution results by providing arbitrary execution IDs. The internal API implements proper validation for both parameters. This is fixed in v0.6.16.

References

Community reviews

Loading reviews…