CVE-2025-54089: Absolute Security Secure Access · Cross-site Scripting
Affects Absolute Security Secure AccessSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium · fixed in 14.10 : update Absolute Security Secure Access when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 14.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Absolute Security Secure Access | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify their Secure Access product version and upgrade to version 14.10 or later where this vulnerability is fixed. In the absence of a patch, organizations should restrict administrative console access to trusted personnel only and enforce strong multi-factor authentication to reduce the risk of compromised admin accounts. Monitoring administrative sessions for unusual activity and implementing strict session timeout policies can limit the window of exploitation. Additionally, organizations should conduct regular security training for administrators to recognize suspicious console behavior and avoid interacting with untrusted inputs. Network segmentation and limiting console access to secure management networks can further reduce exposure. Finally, organizations should engage with Absolute Security for any available security advisories or interim mitigations and apply them promptly.
Description
CVE-2025-54089 is a cross-site scripting vulnerability in versions of secure access prior to 14.10. Attackers with administrative access to the console can interfere with another administrator’s access to the console. The attack complexity is low; there are no attack requirements. Privileges required to execute the attack are high and the victim must actively participate in the attack sequence. There is no impact to confidentiality or availability, there is a low impact to integrity.