CVE-2025-54571: ModSecurity · Unchecked Return Value
Affects ModSecuritySource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.9.12 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade ModSecurity to 2.9.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| owasp-modsecurity ModSecurity | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade ModSecurity to version 2.9.12 or later to remediate this vulnerability. In addition to patching, organizations should implement strict validation and sanitization of HTTP headers within their WAF configurations to prevent unauthorized header manipulation. Deploy Content Security Policy (CSP) headers to mitigate the impact of potential XSS attacks by restricting script execution sources. Regularly audit and monitor web traffic for anomalies, specifically looking for unusual Content-Type header changes or suspicious payloads. Employ runtime application self-protection (RASP) tools to detect and block exploitation attempts in real time. Conduct security awareness training for developers and administrators to recognize and respond to WAF misconfigurations. Finally, integrate vulnerability scanning and penetration testing focused on header manipulation and XSS vectors into the security lifecycle to proactively identify similar issues.
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.
References
- github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-cg44-9m43-3f9v (opens in a new tab)
- github.com/owasp-modsecurity/ModSecurity/issues/2514 (opens in a new tab)
- github.com/owasp-modsecurity/ModSecurity/commit/6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00008.html (opens in a new tab)