CVE-2025-54572: ruby-saml · Uncontrolled Resource Consumption
Affects ruby-samlSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.18.1 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.18.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade ruby-saml to 1.18.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SAML-Toolkits ruby-saml | Affected
| Fixed in
|
AI-suggested
The primary mitigation is to upgrade the ruby-saml library to version 1.18.1 or later, where the vulnerability has been fixed by enforcing message size checks before Base64 validation. Organizations should audit their codebases and dependencies to identify any usage of ruby-saml versions below 1.18.1 and apply the update as a priority. Additionally, implement network-level protections such as rate limiting and web application firewalls (WAFs) to detect and block abnormal SAML response sizes or malformed requests that could indicate exploitation attempts. Monitoring authentication service logs for unusual spikes in SAML response processing times or resource usage can help detect attempted or successful attacks early. Where possible, isolate SAML processing components to limit the impact of resource exhaustion on other services. Finally, incorporate this vulnerability into incident response plans and ensure that security teams are aware of the risk and remediation status.
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.
References
- github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-rrqh-93c8-j966 (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/pull/770 (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/commit/38ef5dd1ce17514e202431f569c4f5633e6c2709 (opens in a new tab)
- github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.1 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00001.html (opens in a new tab)