CVE-2025-54869: Setasign FPDI · Unthrottled Resource Allocation
Affects Setasign FPDISource CVE Database V5
Not known to be exploited · CVSS 6.0 Medium : upgrade to 2.6.3 when convenient.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Setasign FPDI to 2.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Setasign FPDI | Affected
| Fixed in
|
AI-suggested
1. Immediate upgrade of FPDI to version 2.6.3 or later to ensure the vulnerability is patched. 2. Implement strict input validation and file type verification to restrict PDF uploads to trusted sources and scan files for anomalies before processing. 3. Employ resource limits at the PHP runtime level, such as memory_limit and max_execution_time, to prevent excessive resource consumption from any single request. 4. Use sandboxing or isolated processing environments (e.g., containerization) for PDF processing to contain potential crashes and prevent impact on the entire application. 5. Monitor application logs and resource usage patterns to detect unusual spikes indicative of exploitation attempts. 6. Consider implementing rate limiting or CAPTCHA challenges on PDF upload endpoints to mitigate automated attack attempts. 7. Regularly review and update third-party dependencies to minimize exposure to known vulnerabilities.
Description
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.