Skip to main content
CVE-2025-54887VulnerabilityPublished

CVE-2025-54887: jwt ruby-jwe · Improper Validation of Integrity Check Value

Affects jwt ruby-jweSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.1.1 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade jwt ruby-jwe to 1.1.1.

Affected software

ProductAffectedFixed in
jwt ruby-jweAffected
  • <1.1.1
Fixed in
  • 1.1.1

AI-suggested

European organizations should immediately upgrade ruby-jwe to version 1.1.1 or later to remediate this vulnerability. Beyond patching, it is crucial to rotate all encryption keys used with ruby-jwe to invalidate any potentially compromised GHASH keys. Organizations should audit their codebases and dependencies to identify all instances of ruby-jwe usage, including transitive dependencies in Ruby gems. Implement strict cryptographic hygiene by enforcing key management best practices, such as using hardware security modules (HSMs) or secure key vaults for key storage and rotation. Conduct thorough testing to ensure that token validation and encryption behave correctly after the upgrade. Monitor application logs and network traffic for anomalous JWE parsing errors or repeated failed authentication tag validations, which may indicate exploitation attempts. Additionally, consider implementing layered security controls such as Web Application Firewalls (WAFs) with rules to detect and block malformed or suspicious JWE tokens. Finally, update incident response plans to include this vulnerability and train security teams on its detection and mitigation.

Description

jwe is a Ruby implementation of the RFC 7516 JSON Web Encryption (JWE) standard. In versions 1.1.0 and below, authentication tags of encrypted JWEs can be brute forced, which may result in loss of confidentiality for those JWEs and provide ways to craft arbitrary JWEs. This puts users at risk because JWEs can be modified to decrypt to an arbitrary value, decrypted by observing parsing differences and the GCM internal GHASH key can be recovered. Users are affected by this vulnerability even if they do not use an AES-GCM encryption algorithm for their JWEs. As the GHASH key may have been leaked, users must rotate the encryption keys after upgrading. This issue is fixed in version 1.1.1.

References

Community reviews

Loading reviews…