Skip to main content
VulnerabilityPublished

CVE-2025-54940: Advanced Custom Fields (WordPress plugin) · Code Injection

Affects Advanced Custom Fields (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 3.4 Low : upgrade to 6.4.3 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.0 base score
3.4Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.4.3
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Advanced Custom Fields (WordPress plugin) to 6.4.3.

Affected software

ProductAffectedFixed in
WPEngine, Inc. Advanced Custom FieldsAffected
  • <6.4.3
Fixed in
  • 6.4.3

AI-suggested

1. Upgrade the Advanced Custom Fields plugin to version 6.4.3 or later immediately to apply the official fix addressing this vulnerability. 2. Restrict administrative and high-privilege user access to trusted personnel only, and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of privilege abuse. 3. Conduct user training and awareness programs to reduce the risk of social engineering attacks that could trick privileged users into interacting with malicious content. 4. Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of injected HTML. 5. 6. Use web application firewalls (WAF) with rules tailored to detect and block suspicious HTML injection attempts targeting WordPress plugins. 7. Employ security scanning tools that can detect HTML injection and other content manipulation vulnerabilities in web applications. 8. Review and harden user input sanitization and output encoding practices in custom code interacting with the ACF plugin to minimize injection risks.

Description

An HTML injection vulnerability exists in WordPress plugin "Advanced Custom Fields" prior to 6.4.3. If this vulnerability is exploited, crafted HTML code may be rendered and page display may be tampered.

References

Community reviews

Loading reviews…