CVE-2025-55210: FreePBX api · Privilege Context Switching Error
Affects FreePBX apiSource CVE Database V5
Not known to be exploited · CVSS 2.0 Low : upgrade to 17.0.5 or 16.0.17 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.0.5, 16.0.17
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade FreePBX api to 17.0.5 or 16.0.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreePBXapi | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade FreePBX installations to versions 17.0.5 or 16.0.17 or later to apply the official fix. In addition, restrict access to the FreePBX API by implementing strong network segmentation and firewall rules to limit API access only to trusted hosts and users. Rotate and securely store the api-oauth.key private key to prevent unauthorized token generation. Audit and monitor API access logs for unusual token usage or privilege escalation attempts. Implement strict database access controls to protect the api_access_tokens table and prevent leakage of valid jti values. Employ multi-factor authentication for API users to reduce the risk of credential compromise. Regularly review and minimize API scopes granted to users to follow the principle of least privilege. Finally, conduct penetration testing and vulnerability assessments focused on FreePBX API security to identify and remediate any residual weaknesses.
Description
FreePBX is an open-source web-based graphical user interface (GUI) that manages Asterisk. Prior to 17.0.5 and 16.0.17, FreePBX module api (PBX API) is vulnerable to privilege escalation by authenticated users with REST/GraphQL API access. This vulnerability allows an attacker to forge a valid JWT with full access to the REST and GraphQL APIs on a FreePBX that they've already connected to, possibly as a lower privileged user. The JWT is signed using the api-oauth.key private key. An attacker can generate their own token if they possess this key (e.g., by accessing an affected instance), and specify any scopes they wish (e.g., rest, gql), bypassing traditional authorization checks. However, FreePBX enforces that the jti (JWT ID) claim must exist in the database (api_access_tokens table in the asterisk MySQL database) in order for the token to be accepted. Therefore, the attacker must know a jti value that already exists on the target instance. This vulnerability is fixed in 17.0.5 and 16.0.17.
References
- github.com/FreePBX/security-reporting/security/advisories/GHSA-gvgh-p7wj-76cf (opens in a new tab)
- github.com/FreePBX/api/commit/bc6f7d72063cffb18babb6559fa351046d7ad19b (opens in a new tab)
- github.com/FreePBX/api/commit/c16a3a79b83382fb4884e51174882ed635637002 (opens in a new tab)
- github.com/FreePBX/api/commit/d66786634e7e7d3eedcb4d0931b32c415ba6e9ef (opens in a new tab)