CVE-2025-5526: BuddyPress Docs (WordPress plugin) · Insecure Direct Object Reference
Affects BuddyPress Docs (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.3 Medium · fixed in 2.2.5 : update BuddyPress Docs (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BuddyPress Docs | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify the version of BuddyPress Docs installed on their WordPress sites and upgrade to version 2.2.5 or later once available. If you cannot patch yet, administrators should consider disabling the BuddyPress Docs plugin or restricting its use to trusted users only. Implementing strict user role management and minimizing the number of users with document access privileges can reduce exposure. Additionally, monitoring access logs for unusual file access patterns or downloads can help detect exploitation attempts. Organizations should also review and tighten WordPress file permissions and consider deploying web application firewalls (WAFs) with custom rules to block unauthorized access attempts to document URLs. Regular security audits and vulnerability scanning focused on WordPress plugins are recommended to identify and remediate similar issues proactively. Finally, educating users about the importance of account security and monitoring for compromised credentials can help prevent attackers from gaining authenticated access required to exploit this vulnerability.
Description
The BuddyPress Docs WordPress plugin before 2.2.5 lacks proper access controls and allows a logged in user to view and download files belonging to another user