CVE-2025-55288: MGeurts genealogy · Cross-site Scripting
Affects MGeurts genealogySource CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to 4.4.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade MGeurts genealogy to 4.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MGeurts genealogy | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, organizations should upgrade the MGeurts genealogy application to version 4.4.0 or later, where the issue is fixed. Until the upgrade is applied, administrators should restrict access to trusted users only and monitor for suspicious activity indicative of XSS exploitation attempts. Implementing Content Security Policy (CSP) headers can help reduce the impact of XSS by restricting the execution of unauthorized scripts. Additionally, input validation and output encoding should be enforced at the application level to prevent injection of malicious scripts. Organizations should also educate users about the risks of clicking on untrusted links within the application context. Regular security audits and penetration testing focused on web application vulnerabilities can help detect similar issues proactively. Finally, logging and alerting on anomalous user behavior may help identify exploitation attempts early.
Description
Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Reflected Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.