Skip to main content
VulnerabilityPublished

CVE-2025-55671: kujirahand TkEasyGUI · Uncontrolled Search Path Element

Affects kujirahand TkEasyGUISource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 1.0.22 soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.0 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.22
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade kujirahand TkEasyGUI to 1.0.22.

Affected software

ProductAffectedFixed in
kujirahand TkEasyGUIAffected
  • <1.0.22
Fixed in
  • 1.0.22

AI-suggested

  1. Immediate upgrade to TkEasyGUI version 1.0.22 or later once the patch is officially released, as this is the definitive fix for the vulnerability.
  2. Until patching is possible, restrict local access to systems running vulnerable versions of TkEasyGUI to trusted users only, minimizing the risk of local exploitation.
  3. Implement application whitelisting and execution control policies to prevent unauthorized or unexpected executables from running in directories included in the search path.
  4. Educate users about the risks of running untrusted applications or opening suspicious files that might trigger the vulnerability via user interaction.
  5. Conduct thorough audits of systems to identify all instances of TkEasyGUI and verify their versions.
  6. Monitor logs and endpoint detection systems for unusual activity that could indicate exploitation attempts, such as unexpected process launches or privilege escalations.
  7. Employ least privilege principles to limit the permissions of users running TkEasyGUI, reducing the potential impact of code execution.
  8. Review and harden environment variables and system PATH settings to prevent insertion of malicious directories that could be exploited by this vulnerability.

Description

Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.

References

Community reviews

Loading reviews…