Skip to main content
CVE-2025-5690VulnerabilityPublished

CVE-2025-5690: DALIBO PostgreSQL Anonymizer · Information Exposure

Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.2.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade dalibo/postgresql_anonymizer to 2.2.1.

Affected software

ProductAffectedFixed in
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threatsAffected
  • =1
  • =2.0
  • =2.1
  • <2.2.1
Fixed in
  • 2.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately verify if they are using PostgreSQL Anonymizer versions 2.0 or 2.1 with dynamic masking enabled. If so, upgrading to version 2.2.1 or later is critical to remediate the vulnerability. Organizations should audit database user privileges to ensure that only necessary users have access to masked data and that privilege escalation paths are closed. Implement strict access controls and monitor database activities for unusual cursor usage or pg_dump operations that could indicate exploitation attempts. Additionally, consider disabling dynamic masking if it is not essential, as this reduces the attack surface. Regularly review and update anonymization policies and test them against bypass techniques. Employ database activity monitoring (DAM) tools to detect anomalous queries or data access patterns. Finally, ensure that incident response plans include procedures for data exposure incidents related to anonymization failures.

Description

PostgreSQL Anonymizer v2.0 and v2.1 contain a vulnerability that allows a masked user to bypass the masking rules defined on a table and read the original data using a database cursor or the --insert option of pg_dump. This problem occurs only when dynamic masking is enabled, which is not the default setting. The problem is resolved in version 2.2.1

References

Community reviews

Loading reviews…