Skip to main content
VulnerabilityPublished

CVE-2025-57106: Kitware VTK · Heap-based Buffer Overflow

Source CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 9.5.1 : patch affected systems soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

Organizations should immediately audit their use of VTK, identifying any instances up to version 9.5.0, especially those processing GLTF files. Until an official patch is released by Kitware, implement strict input validation and sandboxing for GLTF file processing to prevent malicious data from triggering the overflow. Employ application whitelisting and restrict file sources to trusted origins. Conduct code reviews or use static analysis tools on custom applications embedding VTK to detect unsafe buffer handling. Network-level defenses such as intrusion detection systems should be tuned to detect anomalous GLTF file activity. Additionally, maintain robust endpoint protection and incident response plans to quickly identify and contain potential exploitation attempts. Engage with software suppliers to confirm timelines for patches and request mitigations if VTK is embedded in commercial products.

Description

Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.

References

Community reviews

Loading reviews…