Skip to main content
VulnerabilityPublished

CVE-2025-57164: Flowise · CVE-2025-57164 is a medium severity remote code execution

Affects FlowiseSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.0.5 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade flowiseai/Flowise to 3.0.5.

Affected software

ProductAffectedFixed in
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.0.5
Fixed in
  • 3.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

These include disabling or restricting access to the 'Supabase RPC Filter' feature if not essential, applying strict input validation and sanitization on all user inputs related to RPC filters, and employing web application firewalls (WAFs) to detect and block suspicious payloads targeting this vector. Network segmentation should be enforced to limit the exposure of Flowise instances to untrusted networks. Monitoring and logging of RPC filter usage should be enhanced to identify anomalous or unauthorized commands. Organizations should also review and harden backend Supabase configurations to minimize the impact of potential command execution. Regular security assessments and penetration testing focused on this vulnerability can help identify exploitation attempts. Finally, staying updated with vendor advisories for patches or updates is critical to apply fixes promptly once available.

Description

CVE-2025-57164 is a medium severity remote code execution vulnerability in Flowise up to version 3.0.4. It arises from unsanitized evaluation of user input in the 'Supabase RPC Filter' field, allowing attackers to execute arbitrary code remotely without authentication or user interaction. The vulnerability is linked to CWE-77, indicating improper neutralization of special elements used in commands. Although no known exploits are currently in the wild, the vulnerability poses a risk to confidentiality and integrity. European organizations using Flowise, especially in sectors relying on Supabase integrations, should prioritize patching or mitigating this flaw. The vulnerability’s network attack vector and lack of required privileges increase its risk profile. Countries with higher adoption of Flowise or Supabase-based solutions, such as Germany, the UK, and the Netherlands, are more likely to be affected. Immediate mitigation includes input validation, restricting RPC filter usage, and monitoring for suspicious activity.

References

Community reviews

Loading reviews…