CVE-2025-57709: QNAP Systems Qsync Central · Heap-based Buffer Overflow
Affects QNAP Systems Qsync CentralSource CVE Database V5
Not known to be exploited · CVSS 1.3 Low : upgrade to 5.0.0.4 ( 2026/01/20 ) when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.0.4 ( 2026/01/20 )
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 11 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade QNAP Systems Qsync Central to 5.0.0.4 ( 2026/01/20 ).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc.Qsync Central | Affected
| Fixed in
|
AI-suggested
Organizations should immediately verify their Qsync Central version and upgrade to version 5.0.0.4 or later, where the vulnerability is patched. Since exploitation requires a valid user account, implementing strict access controls and monitoring user account activity is critical. Enforce strong authentication mechanisms, including multi-factor authentication (MFA), to reduce the risk of credential compromise. Network segmentation should be applied to limit access to Qsync Central services only to trusted users and systems. Regularly audit and review user accounts to remove unnecessary or inactive accounts. Employ intrusion detection and prevention systems (IDS/IPS) to monitor for anomalous behavior indicative of exploitation attempts. Additionally, maintain up-to-date backups of critical data to ensure recovery in case of service disruption. Finally, keep abreast of vendor advisories for any updates or additional patches related to this vulnerability.
Description
CVE-2025-57709 is a buffer overflow vulnerability in QNAP Systems Inc. 's Qsync Central version 5.0.x.x. A remote attacker with a valid user account can exploit this flaw to modify memory or crash processes without requiring user interaction. The vulnerability has a low CVSS score of 1.3, indicating limited impact and ease of exploitation. It was fixed in Qsync Central version 5.0.