Skip to main content
CVE-2025-58064VulnerabilityPublished

CVE-2025-58064: ckeditor ckeditor5 · Cross-site Scripting

Affects ckeditor ckeditor5Source CVE Database V5

0

Not known to be exploited · CVSS 2.3 Low · fixed in 45.2.2 : update ckeditor ckeditor5 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 45.2.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

AI-suggested

To mitigate this vulnerability, European organizations should: 1) Immediately upgrade all CKEditor 5 and ckeditor5-clipboard instances to versions 45.2.2 or 46.0.3 or later, where the vulnerability is fixed. 2) Review and audit editor configurations to identify if the HTML embed plugin is enabled or if any custom plugins introduce editable elements with view RawElement enabled; disable or reconfigure these features if not strictly necessary. 3) Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. 4) Conduct thorough input validation and sanitization on any user-generated content before it is passed to the editor, especially if content is imported or embedded from untrusted sources. 5) Monitor web application logs and user reports for suspicious behavior indicative of XSS exploitation attempts. 6) Educate developers and administrators about secure plugin development and configuration practices to prevent similar vulnerabilities. 7) For third-party integrations using CKEditor 5, verify their versions and configurations to ensure they are not vulnerable.

Description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture.ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

References

Community reviews

Loading reviews…