Skip to main content
CVE-2025-58130VulnerabilityPublished

CVE-2025-58130: Apache Fineract · Insufficiently Protected Credentials

Affects Apache FineractSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.12.1 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade org.apache.fineract/fineract to 1.12.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.fineract/fineractpkg:maven/org.apache.fineract/fineractOther threatsAffected
  • <1.12.1
Fixed in
  • 1.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade Apache Fineract installations to version 1.13.0 or later, where the vulnerability is fully patched. 2. Review and enhance credential storage mechanisms to ensure encryption at rest and in transit, minimizing exposure risks. 3. Implement strict access controls and network segmentation to limit exposure of sensitive components. 4. Conduct thorough audits of existing credentials and rotate any potentially compromised secrets. 5. Deploy monitoring and anomaly detection tools to identify unusual access patterns or credential usage. 6. Educate system administrators and developers on secure credential management best practices. 7. Regularly apply security updates and patches to all components of the financial software stack. 8. Engage in penetration testing focused on credential protection to validate mitigations. These steps go beyond generic advice by emphasizing immediate patching, credential hygiene, and proactive monitoring tailored to Apache Fineract environments.

Description

Insufficiently Protected Credentials vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.

References

Community reviews

Loading reviews…