CVE-2025-58137: Apache Fineract · Insecure Direct Object Reference
Affects Apache FineractSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.12.1 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade org.apache.fineract/fineract to 1.12.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.fineract/fineractpkg:maven/org.apache.fineract/fineractOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediately upgrade Apache Fineract installations to version 1.12.1 or later, preferably the latest 1.13.0 release, to apply the official fix. 2. Conduct a thorough audit of access controls and authorization mechanisms related to user-controlled keys within the application to identify any residual weaknesses. 3. Implement strict input validation and sanitization on keys or parameters that influence authorization decisions. 4. Monitor logs for unusual access patterns or unauthorized attempts to manipulate keys or bypass authorization. 5. Employ network segmentation and firewall rules to limit access to Apache Fineract management interfaces to trusted personnel and systems only. 6. Review and enhance privilege management policies to minimize the number of users with elevated privileges that could exploit this vulnerability. 7. Establish an incident response plan specifically addressing potential exploitation of authorization bypass vulnerabilities in financial applications. 8. Engage with Apache Fineract community or vendors for any additional patches or security advisories related to this vulnerability.
Description
Authorization Bypass Through User-Controlled Key vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.