CVE-2025-58357: nanbingxyz 5ire · Cross-site Scripting
Affects nanbingxyz 5ireSource CVE Database V5
Not known to be exploited · CVSS 9.7 Critical · fixed in 0.14.0 : patch nanbingxyz 5ire as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.14.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
AI-suggested
1. Immediate upgrade to nanbingxyz 5ire version 0.14.0 or later, where the vulnerability is patched. 2. Until upgrade is possible, restrict access to the chat page and disable or limit the use of script gadgets and tool integrations that accept external input. 3. Implement network-level controls to block connections to untrusted MCP servers and monitor for anomalous traffic patterns indicative of compromised servers. 4. Educate users on the risks of interacting with unsolicited or suspicious prompts within the 5ire application to reduce successful social engineering attacks. 5. Employ Content Security Policy (CSP) headers if configurable within the application environment to restrict script execution sources. 6. Conduct regular security audits and penetration testing focusing on input validation and integration points within 5ire. 7. 8. Consider isolating the 5ire application within sandboxed environments to limit the impact of potential exploitation.
Description
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Version 0.13.2 contains a vulnerability in the chat page's script gadgets that enables content injection attacks through multiple vectors: malicious prompt injection pages, compromised MCP servers, and exploited tool integrations. This is fixed in version 0.14.0.