Skip to main content
Report · Reddit NetSecAbout CVE-2025-58360Published

CVE-2025-58360: GeoServer XXE Vulnerability Analysis

Affects OSGeo GeoServerSource Reddit NetSec

0
Authoritative record:CVE-2025-58360· High 8.2

Exploited in the wild · KEV due 1 Jan 2026 · public exploit available (Metasploit) · 61% EPSS : upgrade to 2.26.2 or 2.25.6 now.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
61.1% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.26.2, 2.25.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 25 Nov 2025

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 16 days after disclosure

  4. Observed by OffSeq Mirage: evidence found.

    1 exposed host found; no attack traffic recorded

Timeline

  1. CVE published

    on cve.org

    , t = 0

  2. , 16 days after disclosure

  3. In Threat Radar

    record ingested

    , 17 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 37 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OSGeo GeoServer to 2.26.2 or 2.25.6.

Affected software

ProductAffectedFixed in
geoservergeoserverAffected
  • >=2.26.0 <2.26.2
Fixed in
  • 2.26.2
geoservergeoserverAffected
  • <2.25.6
Fixed in
  • 2.25.6

Description

CVE-2025-58360 is a high-severity XML External Entity (XXE) vulnerability affecting GeoServer, an open-source server for sharing geospatial data. This vulnerability allows attackers to exploit XML parsers to read arbitrary files, cause denial of service, or potentially execute remote code. Although no known exploits are currently active in the wild, the vulnerability poses significant risks to organizations relying on GeoServer for geospatial data services. European organizations using GeoServer in critical infrastructure, government, or environmental monitoring could face data breaches or service disruptions. Mitigation requires disabling external entity processing in XML parsers, applying patches once available, and restricting network access to GeoServer instances. Countries with high adoption of geospatial technologies and critical infrastructure reliance on GeoServer, such as Germany, France, the UK, and the Netherlands, are most at risk. Given the ease of exploitation without authentication and the potential impact on confidentiality and availability, this vulnerability is assessed as high severity. Defenders should prioritize vulnerability scanning, configuration audits, and network segmentation to reduce exposure.

References

Community reviews

Loading reviews…