Skip to main content
CVE-2025-58380VulnerabilityPublished

CVE-2025-58380: Brocade Fabric OS · Path Traversal

Affects Brocade Fabric OSSource CVE Database V5

0

Not known to be exploited · CVSS 4.6 Medium : upgrade to 9.2.1 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade brocade/fabric-os to 9.2.1.

Affected software

ProductAffectedFixed in
BrocadeFabric OSAffected
  • =before 9.2.1
Fixed in–
Brocadebrocade/fabric-ospkg:rpm/brocade/fabric-osOther threatsAffected
  • <9.2.1
Fixed in
  • 9.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Brocade Fabric OS to version 9.2.1 or later, where this path traversal vulnerability is fixed. Until the upgrade can be performed, organizations should strictly control and monitor administrative access to the Fabric OS shell, employing strong authentication and access logging. Limiting the number of users with admin privileges and enforcing the principle of least privilege reduces the attack surface. Additionally, organizations should audit existing Fabric OS environments for unusual directory access patterns or shell command usage that could indicate exploitation attempts. Network segmentation of management interfaces and use of multi-factor authentication for admin accounts further reduce risk. Regularly reviewing and updating security policies around SAN management and ensuring timely application of vendor security advisories are also critical.

Description

CVE-2025-58380 is a medium severity path traversal vulnerability in Brocade Fabric OS versions before 9.2.1. It allows an authenticated attacker with administrative privileges to exploit the shell command 'grep' to manipulate path variables and traverse directories outside intended boundaries. This vulnerability requires high privileges and no user interaction, limiting its exploitation scope. Although no known exploits are reported in the wild, successful exploitation could lead to unauthorized access or modification of sensitive files within the system. European organizations using Brocade Fabric OS in their storage area networks (SANs) could face risks to data confidentiality and integrity. Mitigation involves upgrading to Fabric OS 9.2.1 or later and restricting administrative shell access.

References

Community reviews

Loading reviews…