CVE-2025-58466: QNAP Systems QTS · CWE-457
Affects QNAP Systems QTSSource CVE Database V5
Not known to be exploited · CVSS 1.2 Low : upgrade to 5.2.8.3332 build 20251128 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2.8.3332 build 20251128, h5.2.8.3321 build 20251117
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 11 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade QTS to 5.2.8.3332 build 20251128; QuTS hero to h5.2.8.3321 build 20251117.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc.QTS | Affected
| Fixed in
|
| QNAP Systems Inc.QuTS hero | Affected
| Fixed in
|
AI-suggested
European organizations should immediately verify the QTS version running on their QNAP NAS devices and upgrade to QTS 5.2.8.3332 or later, or QuTS hero h5.2.8.3321 or later, as provided by QNAP. Since exploitation requires administrator privileges, organizations must enforce strong access controls, including multi-factor authentication (MFA) for all admin accounts, regular credential audits, and strict password policies. Network segmentation should be applied to isolate NAS devices from general user networks and limit remote administrative access to trusted IPs or VPNs. Continuous monitoring for unusual administrative activities and implementing intrusion detection systems can help detect potential exploitation attempts. Regular backups and disaster recovery plans should be tested to mitigate the impact of potential denial of service. Additionally, organizations should educate administrators on the risks of credential compromise and ensure timely patch management processes are in place to address future vulnerabilities promptly.
Description
CVE-2025-58466 is a low-severity vulnerability in QNAP's QTS operating system caused by the use of an uninitialized variable (CWE-457). It affects QTS version 5.2.x and allows a remote attacker with administrator privileges to cause denial of service or potentially alter control flow in unexpected ways. The vulnerability requires an attacker to already have admin-level access, does not require user interaction, and has no known exploits in the wild. QNAP has released fixes in QTS 5.2.8.3332 and later versions. While the CVSS score is low (1.