CVE-2025-58752: vitejs vite · Relative Path Traversal
Affects vitejs viteSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 5.4.20 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.4.20
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vitejs vite to 5.4.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vitejs vite | Affected
| Fixed in
|
AI-suggested
A fix is available in Vite version 5.4.20 and later. Users should upgrade to version 5.4.20 or newer to remediate this vulnerability. Until then, avoid exposing the Vite dev or preview server to untrusted networks or restrict access appropriately. Patch status is confirmed by the affectedVersions field indicating versions prior to 5.4.20 are vulnerable.
Description
CVE-2025-58752 is a relative path traversal vulnerability in the Vite development server and preview server that allows serving arbitrary HTML files outside the intended root directory. This affects applications that expose the Vite dev server to the network and use appType 'spa' or 'mpa'. The vulnerability arises because certain middleware serving HTML files do not enforce file path restrictions, enabling attackers to retrieve sensitive HTML files from the filesystem. The vulnerability has a low CVSS score of 2.3 and affects Vite versions prior to 5.4.20.
References
- github.com/vitejs/vite/security/advisories/GHSA-jqfw-vq24-v9c3 (opens in a new tab)
- github.com/vitejs/vite/commit/0ab19ea9fcb66f544328f442cf6e70f7c0528d5f (opens in a new tab)
- github.com/vitejs/vite/commit/14015d794f69accba68798bd0e15135bc51c9c1e (opens in a new tab)
- github.com/vitejs/vite/commit/482000f57f56fe6ff2e905305100cfe03043ddea (opens in a new tab)
- github.com/vitejs/vite/commit/6f01ff4fe072bcfcd4e2a84811772b818cd51fe6 (opens in a new tab)