CVE-2025-58766: dyad · Code Injection
Affects dyadSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.20.0 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.20.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade dyad to 0.20.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dyad-sh dyad | Affected
| Fixed in
|
AI-suggested
- Immediate upgrade to Dyad version 0.20.0 or later to apply the official patch that fixes the vulnerability.
- Restrict usage of Dyad to trusted users and environments, especially avoiding loading untrusted or external preview content.
- Implement endpoint protection solutions that monitor and block suspicious code execution behaviors, particularly those attempting to escape container boundaries.
- Enforce strict network segmentation and least privilege principles for users running Dyad to limit potential lateral movement in case of compromise.
- Educate users about the risks of loading unverified content in development tools and incorporate security awareness training focused on social engineering tactics.
- Use application whitelisting and sandboxing technologies to further isolate Dyad processes and prevent unauthorized code execution.
- Monitor logs and system behavior for indicators of compromise related to Dyad usage, such as unexpected process launches or network connections.
- If Docker containers are used, review and harden container configurations to reduce the risk of breakout, including limiting container privileges and capabilities.
Description
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.