Skip to main content
CVE-2025-5889VulnerabilityPublished Updated

CVE-2025-5889: juliangruber brace-expansion · ReDoS

Affects juliangruber brace-expansionSource CVE Database V5

0

Not known to be exploited · CVSS 2.3 Low.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
npmjuliangruber/brace-expansionpkg:npm/juliangruber/brace-expansionOther threatsAffected
  • =1.1.0
  • =1.1.1
  • =1.1.2
  • =1.1.3
  • =1.1.4
  • =1.1.5
  • =1.1.6
  • =1.1.7
  • =1.1.8
  • =1.1.9
  • =1.1.10
  • =1.1.11
  • =2.0.0
  • =2.0.1
  • =3.0.0
  • =4.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of the juliangruber brace-expansion library to versions 1.1.12, 2.0.2, 3.0.1, or 4.0.1 as applicable. 2. Conduct a thorough inventory of software dependencies to identify all instances of the vulnerable library, including transitive dependencies in Node.js projects. 3. Implement runtime monitoring to detect abnormal CPU usage patterns that may indicate exploitation attempts. 4. Employ rate limiting and input validation on endpoints that accept user input potentially processed by brace-expansion to reduce attack surface. 5. Integrate automated dependency scanning tools into CI/CD pipelines to catch vulnerable versions early. 6. Review and harden application logging to capture detailed information on input patterns triggering the expansion function for forensic analysis. 7. Engage with software vendors or third-party providers to confirm patch application if the library is embedded in commercial products. 8. Maintain updated incident response plans that include scenarios for resource exhaustion attacks.

Description

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

References

Community reviews

Loading reviews…