Skip to main content
CVE-2025-58941VulnerabilityPublished Updated

CVE-2025-58941: Fabric (WordPress plugin) · Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File

Affects Fabric (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 1.5.1 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade axiomthemes/fabric to 1.5.1.

Affected software

ProductAffectedFixed in
Packagistaxiomthemes/fabricpkg:composer/axiomthemes/fabricOther threatsAffected
  • <1.5.1
Fixed in
  • 1.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider restricting access to vulnerable endpoints, applying web application firewalls with rules to detect and block suspicious include/require requests, and monitoring for unusual activity related to file inclusion attempts. Avoid deploying affected versions in production environments if possible.

Description

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in axiomthemes Fabric fabric allows PHP Local File Inclusion.This issue affects Fabric: from n/a through <= 1.5.0.

References

Community reviews

Loading reviews…