Skip to main content
CVE-2025-59048VulnerabilityPublished

CVE-2025-59048: openbao-plugins · Incorrect Authorization

Affects openbao-pluginsSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 0.1.1 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade openbao/openbao-plugins/auth-aws to 0.1.1.

Affected software

ProductAffectedFixed in
GitHubopenbao/openbao-plugins/auth-awspkg:github/openbao/openbao-plugins/auth-awsOther threatsAffected
  • <0.1.1
Fixed in
  • 0.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade the openbao auth-aws plugin to version 0.1.1 or later where the vulnerability is patched. 2. Conduct a thorough audit of all IAM roles across AWS accounts interacting with your OpenBao environment to identify and eliminate duplicate role names. 3. Enforce a strict naming convention policy ensuring IAM role names are unique across all AWS accounts within your organization and trusted partners. 4. Implement additional monitoring and alerting for unusual cross-account authentication attempts or role usage patterns. 5. Review and tighten IAM trust policies to restrict which accounts can assume roles, minimizing the attack surface. 6. Use AWS CloudTrail and other logging tools to detect anomalous access patterns indicative of impersonation attempts. 7. Consider isolating critical workloads into dedicated AWS accounts with minimal cross-account role sharing. 8. Educate cloud administrators about the risks of role name collisions and the importance of multi-account security hygiene. These steps go beyond generic advice by focusing on organizational AWS account hygiene and plugin upgrade urgency.

Description

OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.

References

Community reviews

Loading reviews…