Skip to main content
VulnerabilityPublished Updated

CVE-2025-5914: Red Hat Enterprise Linux 10 libarchive · Integer Overflow or Wraparound

Affects Red Hat Enterprise Linux 10 libarchiveSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat Enterprise Linux 10 libarchive to 3.8.0 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libarchive to 3.8.0.

Affected software

ProductAffectedFixed in
libarchiveAffected
  • <3.8.0
Fixed in
  • 3.8.0
GitHublibarchivepkg:github/libarchiveOther threatsAffected
  • <3.8.0
Fixed in
  • 3.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates for affected versions of libarchive in Red Hat Enterprise Linux 8 and 9. Users should apply these updates promptly by following the guidance in Red Hat advisories RHSA-2025:14130 and RHSA-2025:14135 and the update instructions at https://access.redhat.com/articles/11258. Applying these patches mitigates the vulnerability. No additional action is required beyond applying the official fixes.

Description

A vulnerability has been identified in the libarchive library, specifically within the archive_read_format_rar_seek_data() function. This flaw involves an integer overflow that can ultimately lead to a double-free condition. Exploiting a double-free vulnerability can result in memory corruption, enabling an attacker to execute arbitrary code or cause a denial-of-service condition.

References

Community reviews

Loading reviews…