Skip to main content
CVE-2025-59270VulnerabilityPublished Updated

CVE-2025-59270: pspete psPAS · Algorithm Downgrade

Affects pspete psPASSource CVE Database V5

0

Not known to be exploited · CVSS 3.1 Low · fixed in 7.0.209 : update pspete psPAS when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.209
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
pspete psPASAffected
  • =6.4.85
Fixed in–

AI-suggested

European organizations should upgrade psPAS to version 7.0.209 or later, where TLS 1.2 enforcement is implemented to prevent downgrade attacks. Until upgrade, network-level mitigations include enforcing strict TLS policies on endpoints and network devices, disabling deprecated TLS versions (1.0 and 1.1) across the environment, and deploying TLS inspection tools to detect downgrade attempts. Additionally, organizations should monitor network traffic for unusual TLS negotiation patterns indicative of MitM attacks. Employing network segmentation and zero-trust principles can limit exposure of authentication traffic to untrusted networks. Regularly auditing PowerShell modules and scripts for outdated dependencies and enforcing secure coding practices around authentication workflows will reduce similar risks. Finally, educating security teams about the risks of algorithm downgrade attacks and ensuring incident response plans include TLS-related attack scenarios will improve preparedness.

Description

psPAS PowerShell module does not explicitly enforce TLS 1.2 within the 'Get-PASSAMLResponse' function during the SAML authentication process. An unauthenticated attacker in a 'Man-in-the-Middle' position could manipulate the TLS handshake and downgrade TLS to a deprecated protocol. Fixed in 7.0.209.

References

Community reviews

Loading reviews…