Skip to main content
CVE-2025-5934VulnerabilityPublished

CVE-2025-5934: Netgear EX3700 · Stack-based Buffer Overflow

Affects Netgear EX3700Source CVE Database V5

0

Not known to be exploited · CVSS 8.7 High · end of life, no fix coming : replace or isolate Netgear EX3700; no fix will be released.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
None coming – the product is end of life
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

No fix will be released: Netgear EX3700 is end of life. Replace it, or isolate it from untrusted networks until you can.

Affected software

ProductAffectedFixed in
Netgear EX3700Affected
  • =1.0.0.0
  • =1.0.0.1
  • =1.0.0.2
  • =1.0.0.3
  • =1.0.0.4
  • =1.0.0.5
  • =1.0.0.6
  • =1.0.0.7
  • =1.0.0.8
  • =1.0.0.9
  • =1.0.0.10
  • =1.0.0.11
  • =1.0.0.12
  • =1.0.0.13
  • =1.0.0.14
  • =1.0.0.15
  • =1.0.0.16
  • =1.0.0.17
  • =1.0.0.18
  • =1.0.0.19
  • =1.0.0.20
  • =1.0.0.21
  • =1.0.0.22
  • =1.0.0.23
  • =1.0.0.24
  • =1.0.0.25
  • =1.0.0.26
  • =1.0.0.27
  • =1.0.0.28
  • =1.0.0.29
  • =1.0.0.30
  • =1.0.0.31
  • =1.0.0.32
  • =1.0.0.33
  • =1.0.0.34
  • =1.0.0.35
  • =1.0.0.36
  • =1.0.0.37
  • =1.0.0.38
  • =1.0.0.39
  • =1.0.0.40
  • =1.0.0.41
  • =1.0.0.42
  • =1.0.0.43
  • =1.0.0.44
  • =1.0.0.45
  • =1.0.0.46
  • =1.0.0.47
  • =1.0.0.48
  • =1.0.0.49
  • =1.0.0.50
  • =1.0.0.51
  • =1.0.0.52
  • =1.0.0.53
  • =1.0.0.54
  • =1.0.0.55
  • =1.0.0.56
  • =1.0.0.57
  • =1.0.0.58
  • =1.0.0.59
  • =1.0.0.60
  • =1.0.0.61
  • =1.0.0.62
  • =1.0.0.63
  • =1.0.0.64
  • =1.0.0.65
  • =1.0.0.66
  • =1.0.0.67
  • =1.0.0.68
  • =1.0.0.69
  • =1.0.0.70
  • =1.0.0.71
  • =1.0.0.72
  • =1.0.0.73
  • =1.0.0.74
  • =1.0.0.75
  • =1.0.0.76
  • =1.0.0.77
  • =1.0.0.78
  • =1.0.0.79
  • =1.0.0.80
  • =1.0.0.81
  • =1.0.0.82
  • =1.0.0.83
  • =1.0.0.84
  • =1.0.0.85
  • =1.0.0.86
  • =1.0.0.87
  • =1.0.0.88
Fixed in–

AI-suggested

1. Immediate inventory and identification of all Netgear EX3700 devices within the organization's environment, including those in remote or home office locations. 2. Upgrade all affected devices to firmware version 1.0.0.98 or later, which addresses the vulnerability. If upgrading is not feasible due to end-of-life status, plan for device replacement with supported hardware. 3. Segment network architecture to isolate vulnerable devices from critical internal systems, limiting potential lateral movement if compromised. 4. Implement network monitoring and intrusion detection systems to detect anomalous traffic patterns or exploitation attempts targeting these devices. 5. Enforce strict access controls and limit management interfaces exposure to untrusted networks, ideally restricting remote management to VPN or secure channels. 6. Educate users, especially remote workers, about the risks of using outdated networking equipment and encourage reporting of device issues. 7. Collaborate with IT asset management and procurement teams to avoid deploying unsupported or end-of-life devices in the future. 8. Regularly review and update vulnerability management processes to include consumer-grade networking equipment that may be part of the organizational network.

Description

A vulnerability was found in Netgear EX3700 up to 1.0.0.88. It has been classified as critical. Affected is the function sub_41619C of the file /mtd. The manipulation leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.0.98 is able to address this issue. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

References

Community reviews

Loading reviews…