CVE-2025-59388: QNAP Systems Hyper Data Protector · CWE-259
Affects QNAP Systems Hyper Data ProtectorSource CVE Database V5
Not known to be exploited · CVSS 6.6 Medium : upgrade to 2.3.1.455 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.1.455
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade QNAP Systems Hyper Data Protector to 2.3.1.455.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc.Hyper Data Protector | Affected
| Fixed in
|
AI-suggested
Upgrade QNAP Hyper Data Protector to version 2.3.1.455 or later, where this vulnerability has been fixed. No other mitigation is necessary as the vendor has provided an official fix.
Description
CVE-2025-59388 is a medium-severity vulnerability in QNAP Systems Inc. 's Hyper Data Protector version 2.3.x. It is caused by the use of a hard-coded password (CWE-259), which allows remote attackers to gain unauthorized access without any authentication or user interaction. The vulnerability has been fixed in version 2.3.1.455 and later. Exploitation requires no privileges and no user interaction, making it relatively easy to exploit remotely.