CVE-2025-59389: QNAP Systems Hyper Data Protector · SQL Injection
Affects QNAP Systems Hyper Data ProtectorSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.2.4.1 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 2 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade QNAP Systems Hyper Data Protector to 2.2.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc.Hyper Data Protector | Affected
| Fixed in
|
AI-suggested
Upgrade Hyper Data Protector to version 2.2.4.1 or later, where this SQL injection vulnerability has been fixed. No other mitigations are indicated by the vendor advisory.
Description
CVE-2025-59389 is a high-severity SQL injection vulnerability affecting QNAP Systems Inc. 's Hyper Data Protector versions 2.2.x. This vulnerability allows remote attackers to execute unauthorized code or commands without any privileges or user interaction. The issue has been fixed in Hyper Data Protector version 2.2.4.1 and later. There are no known exploits in the wild at this time.