CVE-2025-59417: lobehub lobe-chat · Cross-site Scripting
Affects lobehub lobe-chatSource CVE Database V5
Public exploit available · CVSS 6.8 Medium : upgrade to 1.129.4 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.129.4
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade lobehub lobe-chat to 1.129.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| lobehub lobe-chat | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade all lobe-chat deployments to version 1.129.4 or later, where the vulnerability is patched. Until upgrades are completed, organizations should implement strict input validation and sanitization on any user-generated content or external data fed into lobe-chat, especially SVG content. Employ Content Security Policy (CSP) headers to restrict script execution and mitigate XSS impact. Disable or restrict the rendering of SVG content within chat messages if feasible. Monitor chat logs and network traffic for suspicious payloads or anomalous activity indicative of exploitation attempts. Educate users about the risks of interacting with untrusted chat messages and implement phishing awareness training. Limit integration points and carefully vet third-party tools feeding content into lobe-chat to reduce injection vectors. Employ endpoint detection and response (EDR) tools to detect potential post-exploitation behaviors. Finally, maintain an incident response plan tailored to handle potential RCE incidents stemming from chat platform compromises.
Description
Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.