Skip to main content
CVE-2025-59472VulnerabilityPublished

CVE-2025-59472: vercel next · Vulnerability

Affects vercel nextSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium · fixed in 16.1.5 : update vercel next when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.5, 15.5.9, 15.5.8 +57
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
vercelnextAffected
  • >=15.0.0-canary.0 <15.0.0
  • >=15.0.1-canary.0 <15.0.1
  • >=15.0.2-canary.0 <15.0.2
  • >=15.0.3-canary.0 <15.0.3
  • >=15.0.4-canary.0 <15.0.4
  • >=15.1.0-canary.0 <15.1.0
  • >=15.1.1-canary.0 <15.1.1
  • >=15.1.2-canary.0 <15.1.2
  • >=15.1.3-canary.0 <15.1.3
  • >=15.1.4-canary.0 <15.1.4
  • >=15.1.5-canary.0 <15.1.5
  • >=15.1.6-canary.0 <15.1.6
  • >=15.1.7-canary.0 <15.1.7
  • >=15.2.0-canary.0 <15.2.0
  • >=15.2.1-canary.0 <15.2.1
  • >=15.2.2-canary.0 <15.2.2
  • >=15.2.3-canary.0 <15.2.3
  • >=15.2.4-canary.0 <15.2.4
  • >=15.2.5-canary.0 <15.2.5
  • >=15.3.0-canary.0 <15.3.0
  • >=15.3.1-canary.0 <15.3.1
  • >=15.3.2-canary.0 <15.3.2
  • >=15.1.8-canary.0 <15.1.8
  • >=15.3.3-canary.0 <15.3.3
  • >=15.4.0-canary.0 <15.4.0
  • >=15.3.4-canary.0 <15.3.4
  • >=15.3.5-canary.0 <15.3.5
  • >=15.4.1-canary.0 <15.4.1
  • >=15.4.2-canary.0 <15.4.2
  • >=15.4.3-canary.0 <15.4.3
  • >=15.4.4-canary.0 <15.4.4
  • >=15.4.5-canary.0 <15.4.5
  • >=15.4.6-canary.0 <15.4.6
  • >=15.4.7-canary.0 <15.4.7
  • >=15.5.0-canary.0 <15.5.0
  • >=15.5.1-canary.0 <15.5.1
  • >=15.5.2-canary.0 <15.5.2
  • >=15.5.3-canary.0 <15.5.3
  • >=15.5.4-canary.0 <15.5.4
  • >=15.5.5-canary.0 <15.5.5
  • >=15.5.6-canary.0 <15.5.6
  • >=15.5.7-canary.0 <15.5.7
  • >=15.4.8-canary.0 <15.4.8
  • >=15.1.9-canary.0 <15.1.9
  • >=15.0.5-canary.0 <15.0.5
  • >=15.3.6-canary.0 <15.3.6
  • >=15.2.6-canary.0 <15.2.6
  • >=15.5.8-canary.0 <15.5.8
  • >=15.4.9-canary.0 <15.4.9
  • >=15.3.7-canary.0 <15.3.7
  • >=15.2.7-canary.0 <15.2.7
  • >=15.1.10-canary.0 <15.1.10
  • >=15.0.6-canary.0 <15.0.6
  • >=15.5.9-canary.0 <15.5.9
  • >=15.4.10-canary.0 <15.4.10
  • >=15.3.8-canary.0 <15.3.8
  • >=15.2.8-canary.0 <15.2.8
  • >=15.1.11-canary.0 <15.1.11
  • >=15.0.7-canary.0 <15.0.7
  • >=16.1.0 <16.1.5
Fixed in
  • 16.1.5
  • 15.5.9
  • 15.5.8
  • 15.5.7
  • 15.5.6
  • 15.5.5
  • 15.5.4
  • 15.5.3
  • 15.5.2
  • 15.5.1
  • 15.5.0
  • 15.4.10
  • 15.4.9
  • 15.4.8
  • 15.4.7
  • 15.4.6
  • 15.4.5
  • 15.4.4
  • 15.4.3
  • 15.4.2
  • 15.4.1
  • 15.4.0
  • 15.3.8
  • 15.3.7
  • 15.3.6
  • 15.3.5
  • 15.3.4
  • 15.3.3
  • 15.3.2
  • 15.3.1
  • 15.3.0
  • 15.2.8
  • 15.2.7
  • 15.2.6
  • 15.2.5
  • 15.2.4
  • 15.2.3
  • 15.2.2
  • 15.2.1
  • 15.2.0
  • 15.1.11
  • 15.1.10
  • 15.1.9
  • 15.1.8
  • 15.1.7
  • 15.1.6
  • 15.1.5
  • 15.1.4
  • 15.1.3
  • 15.1.2
  • 15.1.1
  • 15.1.0
  • 15.0.7
  • 15.0.6
  • 15.0.5
  • 15.0.4
  • 15.0.3
  • 15.0.2
  • 15.0.1
  • 15.0.0

AI-suggested

1. Upgrade Next.js to version 15.6.0-canary.61 or 16.1.5 or later, which include patches to limit request body buffering and decompression output size. 2. Audit application configurations to identify use of experimental.ppr or cacheComponents features and the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable; disable these features if not strictly necessary. 3. Implement application-layer request size limits and decompression size limits where possible to prevent large payload processing. 4. Deploy Web Application Firewalls (WAFs) with custom rules to detect and block POST requests containing the 'Next-Resume: 1' header or suspiciously large payloads targeting the PPR resume endpoint. 5. Monitor server memory usage and Node.js process health to detect anomalous spikes indicative of exploitation attempts. 6. Use rate limiting on the PPR resume endpoint to reduce the risk of repeated exploitation attempts. 7. Conduct regular security testing and code reviews focusing on resource consumption vulnerabilities in server-side rendering features. 8. Coordinate with hosting providers or cloud platforms to apply network-level protections against zipbomb and large payload attacks. 9. Educate development teams about the risks of enabling experimental features in production environments without thorough security assessments.

Description

CVE-2025-59472 is a denial of service vulnerability in Vercel Next.js versions with Partial Prerendering (PPR) enabled and running in minimal mode. It allows unauthenticated attackers to send specially crafted POST requests with the 'Next-Resume: 1' header to the PPR resume endpoint, causing the server to exhaust memory and crash. The attack exploits two main issues: unbounded buffering of the request body and unbounded decompression of cached resume data, including a zipbomb-style payload. This leads to a fatal JavaScript heap out-of-memory error, terminating the Node.js process and causing application downtime. Exploitation requires the application to be configured with experimental.ppr or cacheComponents enabled and NEXT_PRIVATE_MINIMAL_MODE=1. The vulnerability has a CVSS score of 5.9 (medium severity) and no known exploits in the wild.

References

Community reviews

Loading reviews…