Skip to main content
CVE-2025-59823VulnerabilityPublished Updated

CVE-2025-59823: gardener-extension-provider-aws · Code Injection

Affects gardener-extension-provider-awsSource CVE Database V5

0

Not known to be exploited · CVSS 9.9 Critical · fixed in 1.64.0 : patch gardener-extension-provider-aws as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.0 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.64.0, 1.55.0, 1.49.0 +1
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade gardener-extension-provider-aws to 1.64.0, 1.55.0, 1.49.0 or 1.46.0.

Affected software

ProductAffectedFixed in
gardener gardener-extension-provider-awsAffected
  • <1.64.0
  • <1.55.0
  • <1.49.0
  • <1.46.0
Fixed in
  • 1.64.0
  • 1.55.0
  • 1.49.0
  • 1.46.0

AI-suggested

European organizations should immediately audit their Gardener installations to identify affected versions of the gardener-extension-provider components. Upgrading to the patched versions (AWS >=1.64.0, Azure >=1.55.0, OpenStack >=1.49.0, GCP >=1.46.0) is critical. Additionally, restrict administrative privileges rigorously to minimize the risk of privilege abuse. Implement strong authentication and authorization controls, including multi-factor authentication for Gardener project admins. Monitor Terraformer usage and infrastructure provisioning activities for anomalous behavior indicative of code injection attempts. Employ network segmentation to isolate seed clusters from less trusted networks and enforce strict access controls. Regularly review and audit cluster logs and configurations for unauthorized changes. Consider deploying runtime security tools that can detect and block suspicious code execution within Kubernetes clusters. Finally, maintain an incident response plan tailored to Kubernetes infrastructure compromises.

Description

Project Gardener implements the automated management and operation of Kubernetes clusters as a service. Code injection may be possible in Gardener Extensions for AWS providers prior to version 1.64.0, Azure providers prior to version 1.55.0, OpenStack providers prior to version 1.49.0, and GCP providers prior to version 1.46.0. This vulnerability could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster where the shoot cluster is managed. This affects all Gardener installations where Terraformer is used/can be enabled for infrastructure provisioning with any of the affected components. This issue has been patched in Gardener Extensions for AWS providers version 1.64.0, Azure providers version 1.55.0, OpenStack providers version 1.49.0, and GCP providers version 1.46.0.

References

Community reviews

Loading reviews…