Skip to main content
CVE-2025-59828VulnerabilityPublished

CVE-2025-59828: anthropics claude-code · Untrusted Functionality Inclusion

Affects anthropics claude-codeSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 1.0.39 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.39
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade anthropics claude-code to 1.0.39.

Affected software

ProductAffectedFixed in
anthropics claude-codeAffected
  • <1.0.39
Fixed in
  • 1.0.39

AI-suggested

European organizations should immediately verify the version of Claude Code in use and ensure it is updated to version 1.0.39 or later. For environments where automatic updates are disabled or manual updates are performed, a prompt update is critical. Additionally, organizations should implement strict controls on the use of Yarn plugins, including auditing and restricting plugin sources to trusted registries. Development environments should enforce policies that require explicit user confirmation before executing code or plugins from untrusted directories. Employing runtime monitoring to detect anomalous plugin executions or unexpected network activity originating from development tools can provide early detection of exploitation attempts. Integrating supply chain security tools that scan for malicious or unauthorized plugins in the Node.js ecosystem can further reduce risk. Training developers to recognize the risks of untrusted directories and plugins and to follow secure development practices is also essential. Finally, organizations should consider isolating development environments or using containerization to limit the impact of potential exploitation.

Description

Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.

References

Community reviews

Loading reviews…