Skip to main content
CVE-2025-59935VulnerabilityPublished

CVE-2025-59935: glpi · Cross-site Scripting

Affects glpiSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 10.0.21 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0.21
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade glpi-project/glpi to 10.0.21.

Affected software

ProductAffectedFixed in
GitHubglpi-project/glpipkg:github/glpi-project/glpiOther threatsAffected
  • 10.0.0 <10.0.21
Fixed in
  • 10.0.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade GLPI installations to version 10.0.21 or later, where the vulnerability has been patched. Organizations should implement strict input validation and output encoding on all user-supplied data, especially on the inventory endpoint, to prevent injection of malicious scripts. Web application firewalls (WAFs) can be configured to detect and block common XSS payload patterns targeting GLPI endpoints. Security teams should monitor logs for unusual or repeated requests to the inventory endpoint that may indicate exploitation attempts. User awareness training should emphasize caution when interacting with inventory pages and recognizing potential phishing attempts that could trigger XSS payloads. Additionally, applying Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting script execution sources. Regular vulnerability scanning and penetration testing focused on web application security will help identify any residual or related weaknesses. Finally, organizations should review and limit GLPI user permissions to reduce the impact scope if exploitation occurs.

Description

CVE-2025-59935 is a medium severity cross-site scripting (XSS) vulnerability affecting glpi-project's GLPI software versions 10.0.0 up to but not including 10.0.21. An unauthenticated attacker can inject malicious scripts via the inventory endpoint, which requires user interaction to trigger. The vulnerability impacts confidentiality by potentially stealing sensitive user data through script execution but does not affect integrity or availability. No known exploits are currently reported in the wild. European organizations using vulnerable GLPI versions for IT asset management should prioritize upgrading to version 10.0.

References

Community reviews

Loading reviews…