Skip to main content
VulnerabilityPublished Updated

CVE-2025-6020: Red Hat Enterprise Linux 10 linux-pam · Path Traversal

Affects Red Hat Enterprise Linux 10 linux-pamSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat Enterprise Linux 10 linux-pam to 1.7.1 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade linux-pam to 1.7.1.

Affected software

ProductAffectedFixed in
linux-pamAffected
  • <1.7.1
Fixed in
  • 1.7.1
GitHublinux-pampkg:github/linux-pamOther threatsAffected
  • <1.7.1
Fixed in
  • 1.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has issued official security advisories with patches addressing CVE-2025-6020 for Red Hat Enterprise Linux 8 and 9.4 Extended Update Support versions. Users should apply the updates as described in Red Hat advisories RHSA-2025:10024 and RHSA-2025:10027. Refer to https://access.redhat.com/articles/11258 for detailed update instructions. Applying these updates mitigates the vulnerability. No additional mitigation steps are required beyond applying the official patches.

Description

A flaw was found in linux-pam. The module pam_namespace may use access user-controlled paths without proper protection, allowing local users to elevate their privileges to root via multiple symlink attacks and race conditions.

References

Community reviews

Loading reviews…