CVE-2025-61639: Wikimedia Foundation MediaWiki · Information Exposure
Affects Wikimedia Foundation MediaWikiSource CVE Database V5
Not known to be exploited · CVSS 1.7 Low : upgrade to 1.39.14 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.39.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Wikimedia Foundation MediaWiki to 1.39.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia FoundationMediaWiki | Affected
| Fixed in
|
AI-suggested
European organizations should take the following specific steps to mitigate CVE-2025-61639: 1) Identify all MediaWiki instances in their environment and verify the version numbers. 2) Prioritize upgrading MediaWiki installations to versions 1.39.14, 1.43.4, or 1.44.1 or later, where the vulnerability is fixed. 3) If immediate patching is not feasible, restrict network access to MediaWiki servers by implementing IP whitelisting or VPN-only access to limit exposure to unauthorized users. 4) Review and harden MediaWiki configuration settings to minimize sensitive data exposure in logs and recent changes, including disabling unnecessary logging features or restricting log visibility. 5) Monitor MediaWiki access logs for unusual or unauthorized access attempts that could indicate exploitation attempts. 6) Educate administrators and users about the importance of timely patching and secure configuration management. 7) Implement web application firewalls (WAFs) with rules to detect and block suspicious requests targeting MediaWiki logging and recent change endpoints. 8) Regularly audit MediaWiki content and logs for sensitive information that should not be publicly accessible. These targeted actions go beyond generic advice by focusing on MediaWiki-specific controls and operational practices.
Description
CVE-2025-61639 is a low-severity vulnerability in Wikimedia Foundation's MediaWiki software that causes exposure of sensitive information to unauthorized actors. It affects multiple program files related to logging and recent changes in MediaWiki versions prior to 1.39.14, 1.43.4, and 1.44.1. The vulnerability allows an unauthenticated attacker to access sensitive data without user interaction. Although the CVSS score is low (1.