Skip to main content
CVE-2025-61641VulnerabilityPublished Updated

CVE-2025-61641: Wikimedia Foundation MediaWiki · Path Traversal

Affects Wikimedia Foundation MediaWikiSource CVE Database V5

0

Not known to be exploited · CVSS 1.7 Low : upgrade to 1.39.14 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
1.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.39.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Wikimedia Foundation MediaWiki to 1.39.14.

Affected software

ProductAffectedFixed in
Wikimedia FoundationMediaWikiAffected
  • < 1.39.14, 1.43.4, 1.44.1
Fixed in
  • 1.39.14

AI-suggested

Organizations should prioritize upgrading MediaWiki installations to versions 1.39.14, 1.43.4, or 1.44.1 or later once patches are officially released by the Wikimedia Foundation. If you cannot patch yet, administrators should restrict access to the API endpoints, especially includes/api/ApiQueryAllPages.php, using network-level controls such as firewalls or web application firewalls (WAFs) to limit exposure. Implement strict input validation and sanitization on any custom extensions or integrations interacting with MediaWiki APIs. Monitor logs for unusual access patterns targeting the vulnerable API. Employ the principle of least privilege on the server to minimize the impact of unauthorized file access. Regularly audit MediaWiki configurations and file permissions to ensure sensitive files are not accessible by the web server user. Finally, maintain an incident response plan to quickly address any exploitation attempts.

Description

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/api/ApiQueryAllPages.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.

References

Community reviews

Loading reviews…