CVE-2025-61643: Wikimedia Foundation MediaWiki · Vulnerability
Affects Wikimedia Foundation MediaWikiSource CVE Database V5
Not known to be exploited · CVSS 2.7 Low : upgrade to 1.39.14 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.39.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U/RE:M/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Wikimedia Foundation MediaWiki to 1.39.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia FoundationMediaWiki | Affected
| Fixed in
|
AI-suggested
European organizations should ensure that all MediaWiki instances are updated to versions 1.39.14, 1.43.4, 1.44.1, or later, as these contain fixes for CVE-2025-61643. In the interim, restricting public access to the recent changes feed or implementing network-level controls to limit exposure of MediaWiki instances can reduce risk. Regularly auditing MediaWiki configurations and logs for unusual activity related to recent changes feeds is advisable. Employing web application firewalls (WAFs) with custom rules to detect anomalous requests targeting the RecentChangeRCFeedNotifier.php endpoint can provide additional protection. Finally, integrating MediaWiki updates into routine patch management cycles ensures timely remediation of this and future vulnerabilities.
Description
CVE-2025-61643 is a low-severity vulnerability in the Wikimedia Foundation's MediaWiki software affecting versions prior to 1.39.14, 1.43.4, and 1.44.1. The issue is located in the RecentChangeRCFeedNotifier.php file, potentially impacting the recent changes feed functionality. The CVSS 4.