Skip to main content
CVE-2025-61667VulnerabilityPublished

CVE-2025-61667: datadog-agent · Incorrect Default Permissions

Affects datadog-agentSource CVE Database V5

0

Not known to be exploited · CVSS 7.0 High : upgrade to 7.71.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.71.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade datadog/datadog-agent to 7.71.0.

Affected software

ProductAffectedFixed in
GitHubdatadog/datadog-agentpkg:github/datadog/datadog-agentOther threatsAffected
  • >=7.65.0 <7.71.0
Fixed in
  • 7.71.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all affected Datadog Linux Host Agent installations to version 7.71.0 or later, where the permission issue is resolved. Until upgrades can be performed, restrict local access to hosts running the vulnerable agent by enforcing strict access controls and monitoring for suspicious activity. Implement host-based intrusion detection systems to detect unauthorized file modifications in the datadog-agent directories. Review and harden file system permissions on the opt/datadog-agent/python-scripts/__pycache__ directory to ensure only privileged users can modify its contents. Conduct regular audits of user accounts and privileges to minimize the risk of low-privilege account compromise. Additionally, consider isolating monitoring agents on dedicated hosts or containers to limit the blast radius of potential exploits. Maintain up-to-date backups and incident response plans to quickly recover from any compromise.

Description

The Datadog Agent collects events and metrics from hosts and sends them to Datadog. A vulnerability within the Datadog Linux Host Agent versions 7.65.0 through 7.70.2 exists due to insufficient permissions being set on the `opt/datadog-agent/python-scripts/__pycache__` directory during installation. Code in this directory is only run by the Agent during Agent install/upgrades. This could allow an attacker with local access to modify files in this directory, which would then subsequently be run when the Agent is upgraded, resulting in local privilege escalation. This issue requires local access to the host and a valid low privilege account to be vulnerable. Note that this vulnerability only impacts the Linux Host Agent. Other variations of the Agent including the container, kubernetes, windows host and other agents are not impacted. Version 7.71.0 contains a patch for the issue.

References

Community reviews

Loading reviews…