CVE-2025-62372: vllm · Improper Validation of Array Index
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 0.11.1 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.11.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm-project/vllm to 0.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade all vLLM deployments to version 0.11.1 or later immediately to apply the official patch that fixes the improper validation issue. 2. Implement strict input validation and sanitization at the application layer to verify embedding input shapes before passing them to vLLM, rejecting malformed or unexpected inputs. 3. Deploy runtime monitoring and anomaly detection to identify unusual input patterns or repeated crashes indicative of exploitation attempts. 4. Use containerization or sandboxing to isolate vLLM processes, limiting the blast radius of potential crashes. 5. Maintain robust incident response plans to quickly recover AI inference services in case of denial of service. 6. Coordinate with AI model providers and infrastructure teams to ensure compatibility and security of multimodal model inputs. 7. Regularly audit and update AI serving infrastructure to keep pace with security patches and best practices. 8. Consider network-level protections such as rate limiting and filtering to reduce exposure to malicious input submissions.
Description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g.hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw (opens in a new tab)
- github.com/vllm-project/vllm/pull/27204 (opens in a new tab)
- github.com/vllm-project/vllm/pull/6613 (opens in a new tab)
- github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b (opens in a new tab)