Skip to main content
VulnerabilityPublished Updated

CVE-2025-6238: AI Engine (WordPress plugin) · Open Redirect

Affects AI Engine (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.0 High.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
tigroumeow AI EngineAffected
  • =2.8.4
Fixed in–

AI-suggested

Organizations should immediately upgrade the tigroumeow AI Engine plugin to version 2.8.5 or later, where the OAuth functionality is disabled and the vulnerable code removed. Until patching is possible, administrators should consider disabling OAuth features or restricting access to the plugin's authorization endpoints via web application firewalls or access control rules. Monitoring web server logs for suspicious redirect attempts or unusual OAuth authorization flows can help detect exploitation attempts. Educating users about phishing risks and suspicious links is critical to reduce successful exploitation via social engineering. Additionally, implementing strict Content Security Policy (CSP) headers and validating all redirect URIs on the server side can provide defense-in-depth. Regular vulnerability scanning and plugin audits should be conducted to identify outdated or vulnerable components.

Description

The AI Engine plugin for WordPress is vulnerable to open redirect in version 2.8.4. This is due to an insecure OAuth implementation, as the 'redirect_uri' parameter is missing validation during the authorization flow. This makes it possible for unauthenticated attackers to intercept the authorization code and obtain an access token by redirecting the user to an attacker-controlled URI. Note: OAuth is disabled, the 'Meow_MWAI_Labs_OAuth' class is not loaded in the plugin in the patched version 2.8.5.

References

Community reviews

Loading reviews…