CVE-2025-62508: StarCitizenTools mediawiki-skins-Citizen · Cross-site Scripting
Affects StarCitizenTools mediawiki-skins-CitizenSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.9.0 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade starcitizentools/mediawiki-skins-Citizen to 3.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubstarcitizentools/mediawiki-skins-Citizenpkg:github/starcitizentools/mediawiki-skins-CitizenOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade the Citizen MediaWiki skin to version 3.9.0 or later to apply the official fix. If you cannot patch yet, restrict the editinterface permission strictly to trusted administrators and review current user roles to ensure minimal assignment. Implement Content Security Policy (CSP) headers to limit the execution of unauthorized scripts within the MediaWiki environment. Regularly audit interface message content for suspicious or unexpected HTML or script injections. Employ web application firewalls (WAFs) with rules targeting XSS patterns to provide an additional layer of defense. Educate administrators about the risks of granting interface editing rights and enforce strict change management procedures for interface messages. Monitor logs for unusual activities related to interface message edits or unexpected script executions. Consider isolating MediaWiki instances or restricting access to sensitive wikis to reduce exposure.
Description
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.
References
- github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-g955-vw6w-v6pp (opens in a new tab)
- github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/e006923c6dbf113c9a025ca186ecc09fe7b93a15 (opens in a new tab)
- github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/fbb1d4fe9627281567706f3f6fc99a42ce16fdc4 (opens in a new tab)